Tuesday, October 14, 2008

Solaris Link Aggregation

Link aggregation or IEEE 802.1AX-2008, is a computer networking term which describes using multiple network cables/ports in parallel to increase the link speed beyond the limits of any one single cable or port, and to increase the redundancy for higher availability.

Most implementations now conform to what used to be clause 43 of IEEE 802.3-2005 Ethernet standard, usually still referred to by its working group name of “IEEE 802.3ad”. The Link Aggregation definition has since been moved to a standalone IEEE 802.1AX standard. (wikipedia.org)


Here’s the sample of setup aggregation link between :

e1000g0 and e1000g1
e1000g2 and e1000g3

Make sure your eeprom’s local-mac-address? variable is set to true (you don’t need this for x86):

# eeprom local-mac-address?
local-mac-address=false

# eeprom local-mac-address? = true

# eeprom local-mac-address?
local-mac-address?=true

1. Unplumb the interfaces to be aggregated:
# ifconfig e1000g0 down unplumb
# ifconfig e1000g1 down unplumb
# ifconfig e1000g2 down unplumb
# ifconfig e1000g3 down unplumb

2. Create a link-aggregation group with key 1 and 2:

{format= dladm create-aggr -d

interface Represents the device name of the interface to become part of the aggregation.
key Is the number that identifies the aggregation. The lowest key number is 1. Zeroes are not allowed as keys.

{passive mode by default:
# dladm create-aggr -d e1000g0 -d e1000g1 1
# dladm create-aggr -d e1000g2 -d e1000g3 2

{active mode:
# dladm create-aggr -l active -d e1000g0 -d e1000g1 1
# dladm create-aggr -l active -d e1000g2 -d e1000g3 2

*please note that, if you configure LACP passive mode on your switch, you have to configure active mode on your server. if both in passive mode, they do not exchange LACP packets. check your configuration with “dladm show-aggr -L” command.

# dladm show-link aggr1
# dladm show-link aggr2

3. Plumb up the interface aggrkey, add ip address:

# ifconfig aggr1 plumb
# ifconfig aggr2 plumb

# ifconfig aggr1 192.168.1.1 netmask 255.255.255.0 up
# ifconfig aggr2 192.168.1.2 netmask 255.255.255.0 up

4. Show link aggregation status:

# dladm show-aggr >>check the status
# dladm show-aggr -s >>to display statistics
# dladm show-aggr -L >>to display LACP specific information

5. Make the IP configuration of the link aggregation persist across reboots

create “/etc/hostname.aggrkey” file
# vi /etc/hostname.aggr1
192.168.1.1
# vi /etc/hostname.aggr2
192.168.1.2

# dladm modify-aggr -t -l passive 1 {change aggr1 to passive mode; temporary only]
# dladm modify-aggr -t -l active 1 {change aggr1 to active mode; temporary only]

for further reference:

http://docs.sun.com/source/820-3084-10/link_aggregation.html

Read the rest of this entry...

Bookmark and Share My Zimbio http://www.wikio.com

Friday, October 10, 2008

Link aggregarion and Logical Interfaces

The two ends of the network interface configuration spectrum are -

"Link aggregation, or IEEE 802.3ad, is a computer networking term which describes using multiple Ethernet network cables/ports in parallel to increase the link speed beyond the limits of any one single cable or port, and to increase the redundancy for higher availability." (ref: http://en.wikipedia.org/wiki/Link_aggregation)

- and -



Link Aggregation and Logical Interfaces

Logical interfaces allow you to assign multiple IP addresses to a single physical interface, and share the bandwidth of a single interface across multiple IP addresses.



Link Aggregation:
Over the years there have been a couple ways to configure link aggregation on Solaris, the current method is via the 'dladm' command. Here's a script to detect all physical interfaces on your host and create a single aggregated link assigned the name 'aggr1'.

#!/bin/sh

if [ $# -lt 1 ]; then
echo "Usage: ./trunk.sh [ip address]"
exit 1
fi

interfaces=`dladm show-link | grep -v LINK | awk '{print $1}'`
dladm_cmd="dladm create-aggr -l passive"
for i in $interfaces; do
dladm_cmd="${dladm_cmd} -d $i"
done
dladm_cmd="${dladm_cmd} 1"

echo "
To enable trunking, execute the following commands:

${dladm_cmd}
ifconfig aggr1 plumb ${1}/24 up
dladm show-aggr
echo \"${1}\" > /etc/hostname.aggr1
svcadm disable network/physical:nwam
svcadm enable network/physical:default
"
exit 0


Examples of dladm command output used in the script:
# dladm show-link
LINK CLASS MTU STATE OVER
e1000g4 phys 1500 up --
e1000g0 phys 1500 up --
e1000g2 phys 1500 unknown --
e1000g1 phys 1500 up --
e1000g3 phys 1500 unknown --
e1000g5 phys 1500 up --

Create link aggregation named 'aggr1', using interfaces e1000g1, e1000g4 and e1000g5:
# dladm create-aggr -l passive -d e1000g1 -d e1000g4 -d e1000g5 1


Show status of aggr1 interface:
# dladm show-aggr
LINK POLICY ADDRPOLICY LACPACTIVITY LACPTIMER FLAGS
aggr1 L4 auto passive short -----

Note that to use this feature you must coordinate with you network switch administrator. The policy and and aggregated interfaces must configured identically on the other end of the ethernet cables ...


We use the Link Aggregation Control Protocol (LACP) in passive mode to control simultaneous transmission on multiple interfaces. Any single stream is transmitted completely on an individual interface, but multiple simultaneous streams can be active across all interfaces.

Logical Interfaces:
A single physical interface can be assigned multiple IP addresses - you may have already seen this in my earlier post on zones, where I configured a set of zones to share a single physical network interface.


Use /network/physical:default service to manage network interfaces:
# svcadm disable svc:/network/physical:nwam
# svcadm enable svc:/network/physical:default


Example: Configure a second address on interface bge0
# ifconfig bge0
bge0: flags=201000843 mtu 1500 index 2
inet 192.168.1.200 netmask ffffff00 broadcast 192.168.1.255

# ifconfig bge0:1 plumb
# ifconfig bge0:1 172.0.1.111/24 up
# ifconfig bge0:1
bge0:1: flags=201000843 mtu 1500 index 2
inet 172.0.1.111 netmask ffffff00 broadcast 172.0.255.255


That was simple ! Your bge0 interface now participates on two subnets: 192.168.1.0/24 and 172.0.1.0/24.


To make this bge0:1 configuration permanent, create the file /etc/hostname.bge0:1 containing the ip address 172.0.1.111. Your logical interface will be initialized each time you boot your system.


Read the rest of this entry...

Bookmark and Share My Zimbio http://www.wikio.com

Sunday, September 21, 2008

IPhone not just a toy

I decided to write this article regarding my iPhone, and guess what? It is not just a small thing, the phone is on the march. Even afraid of blackberry iPhone, the latest news is that a pause in the business sector. BlackBerry to be afraid, that has little whenever they need or want. And no, I am not affliated with Apple Inc.

There are many applications that make my life easier. But this is a blog about Tech. How can a coin with the iPhone. There are two ways. Applications and websites dedicated to the iPhone. There was a story of how a game maker did a million dollars from a game that took him to one day (sorry can not copy / paste in the iPhone). Actually make a request Preety is easy with the SDK package from Apple. It's just a matter that requires a Macintosh.

Websites are a great idea, and it has a huge market and dedicated. One idea is an iPhone game review. Even something like YouTube alternal might work if you want to go farther than it could reach more ideas. An idea that comes to mind is what does the 60% of the population and monitoring are on 38%. Pornographery. It is a huge market and has a large user base iphone.

Read the rest of this entry...

Bookmark and Share My Zimbio http://www.wikio.com

Tuesday, August 19, 2008

Googel and Gogle is Google? Googol Huuuh?

What the heck is Googel? Have you ever heard of Gogle? In most cases you must have arrived here when you typed in the word “Gogle” or “Googel” or “Googol“. It will be safe to assume that you are looking for the world’s 4th most visited site Google, well according to Alexa anyway =D


This is a keyword was discovered and shared by Eli. Googel word makes no sense but doing a deeper (naks...) search for shows that it is also the name of a Sesame Street television character (remember Sesame Street?).


So many people are making these typos, that I've also found a site dedicated on typos like these: google, googel, googol and gogle. This site is ranked 600,000 by alexa therefore giving us the notion that it's getting it's share of the traffic.

Hey, people are just people...and some or most of us are really fond of writing about typos lol, to give you an idea there is even a goole that lacks the letter “G”. googl lacks the letter “E”. boggle, the letter “B” is found below the letter “G” in your keyboard. gooogle is a domain redirected to google.com. googol is for non-english speaking searchers. Here are other common typos aside from Googel, Gogle and Googol:

* googlr
* goolge
* googal
* boogle
* bogel
* googgle
* ggogle
* gogol
* gobble
* vogel
* goold
* oogle
* gooe
* goggel
* giggle
* googe
* goolgle
* boole
* gogel
* gogole
* toggle
* googole
* googie
* gogos
* gooole
* gooya
* toogle
* foogle
* poogle
* bogle
* gogal
* googlw
* gppgle
* gooble
* googoo
* fogle
* googlle
* googile
* goble
* gogool
* goofle
* gloogle
* ggoogle

Whew...that's a lot =D

Googel is a typo of Google. Gogle, who knows =D but still is a typo of google and Googol is the most common typo of non-english searchers when they search for google.

Read the rest of this entry...

Bookmark and Share My Zimbio http://www.wikio.com

Tuesday, February 26, 2008

Copying and Installing Your Nintendo DS Lite Game ROMs In Your R4DS

I assume that you use Windows XP or higher and you have sufficient computer skills to follow through.


1. Unzip the zip file you’ve downloaded using your favorite unzip application. Keep it stored in a safe place for future use.


2. Remove your microSD card from the R4DS cartridge.

3. Insert your microSD card to the microSD USB adaptor that you got when you bought your R4DS.

4. Insert the microSD USB adaptor (where your microSD card is inserted) to your PC’s USB port. Windows will automatically detect it.

5. Go to My Computer. You’ll see a new drive in it. That’s your microSD card. Double click it.

6. Copy the .NDS file that you unzipped on step 1 and paste it on the drive that you opened on step 5. Never paste it to any directory. Just paste it on the root directory. You only need to copy the .NDS files, no more, no less, just ignore the other files that goes with the zip file.

7. Safely remove your USB drive when done copying all the NDS files. It was simple right? Now you know how to copy DS Lite games into your R4DS.

8. Remove the microSD card from the microSD USB adaptor.

9. Insert the microSD card to your R4DS cartridge.

10. Insert your R4DS cartridge to your Nintendo DS Lite.

11. Turn on your Nintendo DS Lite. If you followed all the directions above correctly, you’ll be able to see the copied games on the list of games on your R4DS now. You can now enjoy playing your DS Lite games!

Caution:

Unless you have the original copy of the game and you’re just copying the backup is not illegal. It's what you do with it that could make it illegal. Just copy your back-up games and enjoy playing!

Read the rest of this entry...

Bookmark and Share My Zimbio http://www.wikio.com

Monday, February 25, 2008

Nintendo DS Lite Roms Download (for NDS Games)

I've always been a fan of video games,have owned game console since I can image. One of my favorites is the NDS Lite or Nintendo DS Lite.

The DS portable gaming console is such a hit that a lot of games now are produced solely for the DS Lite. I’ve been searching a lot of websites through google and thank goodness I found some ROM sites.

The websites that offer free downloads of Nintendo DS Lite games ROMs in zip file formats are ROM Site and nds-roms. Please take into consideration that these websites do offer DS Lite games but you have to be patient in downloading each games.

Though remember, alway download at your own risk.

Some of the DS Lite games available are:

Spider-Man 2 (Activision)
One Piece (Bandai)
Dragon Ball Z (Banpresto)
MegaMan Battle Network DS
Viewtiful Joe (Capcom)
Gyakuten Saiban (Capcom)
Need for Speed (EA)
Dynasty Warriors (KOEI)
Frogger 2005 (Konami)
Mr. Driller (Namco)
Project Rub (Sega)
Final Fantasy: Crystal Chronicles DS rom from Square Enix
Dragon Quest Monsters
Dark Reflections (MezCo Studios)
The URBZ: Sims in the City
(EA)Super Monkey Ball DS (Sega)
Phantasy Star Online DS (Sega)
Puyo Puyo DS (Sega)
Madden NFL 2005 (EA)

Read the rest of this entry...

Bookmark and Share My Zimbio http://www.wikio.com

Tuesday, January 1, 2008

Making WoW Character

Here's a video on how to make your World of Warcraft character:



Read the rest of this entry...

Bookmark and Share My Zimbio http://www.wikio.com